On 06/23/2016 01:48 PM, Michał Górny wrote: > It would be best if we could kill the old way but I doubt it's a good idea > right now.
Yeah I was sad when I realized a nice naming scheme just barely wasn't going to work thanks to EGIT_LIVE_REPO_URI being shortened to EGIT_LIVE_REPO, but I didn't want to break it. The other thing is the associative arrays not being exportable so if we want something that can work for interactive use / make.conf / package.env then we almost need both. > One request though: don't use PN but CATEGORY/PN. True. I wasn't sure just how far to go with it. If you really wanted to go all-out I could split arbitrary atoms with versionator and figure out a custom lookup function to match up keys-values... but ugh. I'll just do CATEGORY/PN for now. :) (There's a branch for this here for reference): https://github.com/ormaaj/gentoo/blob/git-r3-live-arrays/eclass/git-r3.eclass
signature.asc
Description: OpenPGP digital signature
