On Thu, 23 Jun 2016 14:28:39 -0500 Dan Douglas <[email protected]> wrote:
> On 06/23/2016 01:48 PM, Michał Górny wrote: > > It would be best if we could kill the old way but I doubt it's a good idea > > right now. > > Yeah I was sad when I realized a nice naming scheme just barely > wasn't going to work thanks to EGIT_LIVE_REPO_URI being shortened to > EGIT_LIVE_REPO, but I didn't want to break it. > > The other thing is the associative arrays not being exportable so if we > want something that can work for interactive use / make.conf / package.env > then we almost need both. > > > One request though: don't use PN but CATEGORY/PN. > > True. I wasn't sure just how far to go with it. If you really wanted > to go all-out I could split arbitrary atoms with versionator and figure out a > custom lookup function to match up keys-values... but ugh. I'll just do > CATEGORY/PN for now. :) Well, just to be clear I don't like that magic either. However, I wanted to preserve it for compatibility with old git-2 eclass, i.e. so that when ebuilds are updated from git-2 to git-r3 people's overrides won't suddenly stop working. Originally I just wanted to expect people to override EGIT_REPO_URI via package.env but that won't work since ebuilds would override it. -- Best regards, Michał Górny <http://dev.gentoo.org/~mgorny/>
pgpRfL6c10vZY.pgp
Description: OpenPGP digital signature
