Attention is currently required from: laforge, pespin.

Hello Jenkins Builder, laforge, pespin,

I'd like you to reexamine a change. Please visit

    https://gerrit.osmocom.org/c/osmo-msc/+/43237?usp=email

to look at the new patch set (#6).

The following approvals got outdated and were removed:
Verified+1 by Jenkins Builder


Change subject: sgs_iface: clean up code in function decode_mme_name
......................................................................

sgs_iface: clean up code in function decode_mme_name

The function decode_mme_name is a bit hard to read and also has
some minor problems we can optimize.

- Do not call TLVP_LEN each time we need the length of the
  TLV IE. Call it once and keep the value in a variable.
- mme_name_enc holds the value part of the TLV IE, we can
  use this variable instead of calling TLVP_VAL all all
  the time.
- When we have copied the value part of the TLV IE using
  memset, let's ensure that the string is terminated.
- Add/fix spec references and improve comments so that it
  is more clear how the decoding actually works.

Related: OS#7058
Change-Id: I9aec8300f15264b68ac8e7805e93e621b12cafb2
---
M src/libmsc/sgs_iface.c
1 file changed, 17 insertions(+), 7 deletions(-)


  git pull ssh://gerrit.osmocom.org:29418/osmo-msc refs/changes/37/43237/6
--
To view, visit https://gerrit.osmocom.org/c/osmo-msc/+/43237?usp=email
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings?usp=email

Gerrit-MessageType: newpatchset
Gerrit-Project: osmo-msc
Gerrit-Branch: master
Gerrit-Change-Id: I9aec8300f15264b68ac8e7805e93e621b12cafb2
Gerrit-Change-Number: 43237
Gerrit-PatchSet: 6
Gerrit-Owner: dexter <[email protected]>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <[email protected]>
Gerrit-Reviewer: pespin <[email protected]>
Gerrit-Attention: laforge <[email protected]>
Gerrit-Attention: pespin <[email protected]>

Reply via email to