I have just tried compiling gimp-1.2.4-pre1 on Solaris, and I had some
problems because of the new dependency on gimp-print (which was part of
the GIMP package until 1.2.3).

I tried to see that from the point of view of a novice user who does
not know exactly what is provided by each package, instead of taking
the point of view of a GIMP developer who knows the history of both
packages.  And at first sight, it looks like there is a circular
dependency: in order to build the GIMP, you need libgimpprint, which
is part of the gimp-print package (and you need a version >= 4.2.0).
But in order to build gimp-print, you need the GIMP!

At least, that's how it looks like at first sight, and unfortunately
the way to solve this problem is not explained clearly in the INSTALL
file of the GIMP.  I think that two solutions are possible:
- build the GIMP first with --disable-print, install it, and then
  build and install gimp-print (later, the GIMP can be upgraded with
  --enable-print since libgimpprint will be found)
- build gimp-print with the option --without-gimp, install it, and
  then build and install the GIMP (later, gimp-print can be upgraded
  --with-gimp since the GIMP will be found)

This is a bit confusing.  In fact, I am wondering if it was really a
good idea to remove the files from the GIMP distribution and to
introduce an external dependency...  That's why I am posting this
question here.

Unfortunately, even the procedure described above did not work too
well with Solaris, probably because the latest version of gimp-print
contains some Linuxisms that haven't been debugged yet (I will send a
separate bug report to the gimp-print team later).  I started by
configuring gimp-print 4.3.0 with the following options:

./configure --prefix=/Local --without-cups --without-foomatic --without-ijs 
--without-gimp

Then I built it and installed it.  Then I tried to configure the GIMP
again, hoping that it would now recognize libgimpprint.  But here is
what I got:

./configure --prefix=/Local
[...]
checking for gtkdoc-mkdb... false
checking for sendmail... /usr/lib/sendmail
checking for gimpprint-config... /Local/bin/gimpprint-config
checking for gimpprint >= 4.2.0... /Local/bin/gimpprint-config: syntax error at line 
27: `;' unexpected
expr: syntax error
configure: warning: 
*** libgimpprint version  is too old.
*** You need at least version 4.2.0.
configure: error: 
*** Check for libgimpprint failed. You can download it from 
*** http://gimp-print.sourceforge.net/ or you can build without it by passing 
*** --disable-print to configure (but you won't be able to print then).

There are two (probably trivial) problems: a syntax error in
gimpprint-config (works with bash but not with the standard /bin/sh)
and an incorrect diagnostic from the gimp's configure script.  These
problems can probably be solved easily (I don't have the time to do
that now but I will try next week) but it is a pity that the first
impression of 1.2.4-pre1 on Solaris is not as positive as I was hoping
for.  Building with --disable-print works, but it's a pity to loose
support for printing.

I would prefer to have some parts of gimp-print back into the main
GIMP package.  This would not be the latest and greatest version and
it may not support all printing systems, but at least it would work
with that version of the GIMP and the users would always have the
option to upgrade gimp-print separately.  I think that it would be
better to have one package that provides the basic stuff including
printing support without having circular dependencies between two
packages (even if the workaround is easy).

-RaphaŽl
_______________________________________________
Gimp-developer mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-developer

Reply via email to