On Fri, Jul 25, 2003 at 01:57:15PM -0300, Joao S. O. Bueno wrote:
> Hi.
> I do not know the X11 license, but changing the license of
> the plugin template recalls me of one thing:
> If the GIMP is under the GPL, with no exceptions listed were 
> appropriate, them it is ilegal for non GPL-compatible plugins to be 
> installed.
> This is quite clear on the GPL-FAQ.
> And for great that it may seen for some people to have some proprietary
> plugins developed for the GIMP, that otherwise would not, we get
> better respecting the GPL or __else__.
> To allow for non gpl-compatible plugins to run with the GIMP, the 
> license of the GIMP itself must include an exception note, stating that.

The libraries needed for a GIMP plug-in are licensed under the LGPL. The
way the architecture is now, plug-ins don't link against the app directly.

Gimp-developer mailing list

Reply via email to