Sven Neumann <[EMAIL PROTECTED]> writes:

> > and anyway, maybe adding a few ifdef round gimp code using
> > specific 2.2.x features if it can safely be disabled may help
> > users of older releases or other distros.
> We did that for a while. It not only became difficult to maintain
> but at some point it became apparent that gtk+-2.0 just had too many
> bugs that could not be worked around. The current code still has
> some ifdefs that enable workarounds for bugs in gtk+ before version
> 2.2.2. We do this in order to avoid a dependency on 2.2.2 but at
> some point before gimp-2.0, we will have to drop these workarounds
> and depend on gtk+-2.2.2 or newer.

sure, when woraounding old bugs became too much development time
consuming, it's better to just bump the requires.

what's more, the odds are high that all distributors that will ship
gimp-2.0 will ship gtk+-2.2.x too

Gimp-developer mailing list

Reply via email to