Hi,

On Monday I downloaded the latest gimp-1.3.21, expecting to be able to
have a sparkling new version to play with by sometime that afternoon. 
No such luck.  I'm running into the following problem:

checking PANGOFT2_CFLAGS... -I/usr/include/pango-1.0
-I/usr/include/freetype2 -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include
checking PANGOFT2_LIBS... -Wl,--export-dynamic -lpangoft2-1.0
-lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
checking for fontconfig >= 2.2.0... Requested 'fontconfig >= 2.2.0' but
version
of Fontconfig is 1.0.1
 
configure: error: Library requirements (fontconfig >= 2.2.0) not met;
consider adjusting the PKG_CONFIG_PATH environment variable if your
libraries are in a nonstandard prefix so pkg-config can find them.

So far this loks straightforward -- I need a later version of
fontconfig, right?  So I go download the fontconfig-2.2.1-4.i386.rpm and
the fontcnfig-devel-2.2.1-4.i386.rpm from RedHat and try to upgrade. 
Well, the upgrade doesn't quite work: 

[EMAIL PROTECTED] RPMS]# rpm -Uvh --oldpackage fontconfig*2.1-9*.rpm
Preparing...                ###########################################
[100%]
   1:fontconfig             ###########################################
[ 50%]
error: %post(fontconfig-2.1-9) scriptlet failed, exit status 127
   2:fontconfig-devel       ###########################################
[100%]

But after a little fiddling I seem to have 2.2.1-9 installed.  But then
I cannot get past the gtk+ tests, bacause there's a problem with
FT_Get_BDF_Property being undefined in /usr/lib/fontconfig.so.1.

After two days of beating my head against this, I'm asking for help.  I
must be doing something wrong, probably something really simple, but it
feels like I'm looking at the problem from the wrong angle.  

Does gimp-1.3.21 suddenly need fontconfig-2.2.0 or greater, where
gimp-1.3.20 didn't?  Am I somehow screwing up the rpm upgrade from the
original RH9 install (fontconfig-2.1-9)?  If so, how should I try to get
rpm to upgrade when there are dependencies like
fontconfig/fontconfig-devel involved?  Or is my download somehow corrupt
and I should try it again?

TIA,
-- 

--Jeff

Jeff Trefftzs <[EMAIL PROTECTED]>
http://www.tcsn.net/trefftzs                    Home Page
http://gug.sunsite.dk/gallery.php?artist=68     Gimp Gallery
http://trefftzs.topcities.com/                  Photo Gallery 

_______________________________________________
Gimp-developer mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-developer

Reply via email to