Kevin Cozens <[EMAIL PROTECTED]> writes:

> For example, if I look in DB Browser for creating a new image, one of
> the enums shown for argument type is GIMP_RGB_IMAGE. So, since I know
> for Script-Fu scripts I use - in place of _, I would use
> GIMP-RGB-IMAGE. When I try running a script with this as things stand
> now, I will get an error message and be left scratching my head
> wondering what is wrong with the script since I followed the
> information shown in DB Browser.

So the easiest solution would be to make script-fu accept the enums
with or without prefix.

> If we are to make such a change, now is the time to do it.

The point is that it is already way too late to do any major
incompatible change. Our API was frozen from the moment we did the
first 2.0pre release.

However I don't see any problem in accepting a patch for Script-Fu
that makes it accept enums prefixed with "GIMP-". Should be a trivial

> The next opportunity to make a change would be for 2.2 which might
> be another year or two down the road but one wouldn't expect such
> incompatibilities in a "minor" bump in version (2.0 to 2.2).

Since we want 2.2 to be API compatible with 2.0, we couldn't do an
incompatible change for 2.2. On the other hand 2.2 is scheduled for
this summer, not in a year or two.

Gimp-developer mailing list

Reply via email to