On Sunday 06 February 2005 05:44, Sven Neumann wrote:
> This looks as if you installed pango into a prefix that is not
> searched by the linker. You will have to either 
modify /etc/ld.so.conf
> to include that path, or set the LD_LIBRARY_PATH environment 
variable.
> 
> 
> Sven

This helped and I was able to find the problem.  I had 2 copies of 
Pango installed in different locations.  I removed the incorrect one 
and then double checked everything related to GTK and GIMP to make 
sure there was only one copy and that these were installed in a way 
that was consistent with the SuSE RPMs.  Which they were.  I then 
restarted the GTK installation starting with GLIB just to make sure.  

There were no apparent problems during the build process and I tested 
GIMP as each new library was installed.  Everything worked until I 
installed GTK then GIMP, Firefox, GKrellM and other GTK dependant apps 
started failing with a libgtk-x11-2.0.so: undefined reference to 
'gdk_threads_unlock' error.  As soon as I backed out GTK to the 
version from the distro these apps started working again.  By the way 
this is the same error message I got when I installed gtk 2.4 from the 
ULB SuSE RPMs.

I checked on the gtk-list archive to see if this error had been 
reported.  There was one short thread about this error message (4 
emails).  But the fix information is not in the thread.  Either 
because it was never fixed or the information was communicated off 
list.

So the state of my machine now is that I have glib 2.6.2, Pango 1.8 and 
ATK 1.9 installed but I still have gtk 2.2.4 installed.  Everything is 
working but of course I can not install any version of GIMP newer than 
2.0.x.   Anyone have any clues about what I need to do to get gtk 2.6 
installed?

-- 
Hal V. Engel

Attachment: pgp1Rh3R8Bh4x.pgp
Description: PGP signature

Reply via email to