On Fri, 16 Feb 2007 13:01:16 +0100, Robert L Krawitz <[EMAIL PROTECTED]>  

>    Date: Fri, 16 Feb 2007 09:33:40 +0100
>   There is also problems with the way changes broke the interface
>    with gimp=print, amongst other things. Gimp 2.3 is still seriously
>    unfinished as far as the print dlg goes yet it seems I still cannot
>    use gutenprint with 2.2.
> What problem are you having using Gutenprint with GIMP 2.2?  It should
> work fine, and I'd like to help you fix it.


I only just noticed this comment at the top of your reply.

The problem is that my distro , Gentoo, has a dependancy block on  
gimp-print>4.2.7 with gimp-2.2

Now from what you say this may be an error or a misunderstanding of old  
issues. I recall quite some time ago I put in a bug report at  
bugs.gentoo.org and got this was an "upstream" issue and the block would  
remain until that was resolved.

If you can help me fix this issue , which may be infact a non-issue, you  
may help clear this up for all Gentoo users as well.

It seems the crux of the issue is version checking done by gimp  
precompilation checks.


According to configure.in:

m4_define([gimpprint_required_version], [4.2.0])
m4_define([gimpprint_suggested_version], [4.2.6])
m4_define([gimpprint_toonew_version], [4.3.0])

Therefore, if you use >=4.2.*, gimp maintainers don't support it.

The ebuilds will stay how they are until the maintainers say that its okay  
to use a later ( probably non-beta ) version of gimp-print.

Thanks for reporting!

Is the conclusion from this that the src tarball for gimp 2.2.x needs  
these checks to be changed because gimp-print-5.x does now work with it?

Gimp-developer mailing list

Reply via email to