The problem I'm having is apparently not common, as I'm sure there would be huge
outcry if it were.  But I just can't figure out how to resolve it.

Sometime shortly after I upgraded from 2.6.? to 2.8.2, but not immediately, I
lost the ability to drag and drop elements in the user interface.  For example,
if I have multiple layers and I want to reorder them, I can't simply drag one to
a new position.  Clicking and dragging seems to be working.  The layer starts to
follow the mouse.  But there is no indication under the mouse of where it will
end up (no black line showing between layers).  And when I release the mouse
button, nothing happens.  The layers remain in their original order.

A similar issue exists for docked dialogs.  If I want to reorder the tabs of
docked dialogs, like tool options, layers, paths, etc., I click and drag one to
a new location.  But instead of reordering them, it simply undocks the one I
tried to move.  And I can't re-dock it.  It always just moves the individual
dialog window to the new location.

One other possibly related issue is that I have problems using the buttons in
these dialogs.  The first time I click a button, like the "new layer" button, it
usually works.  But after that, no buttons work.  Clicking them just selects
them (dashed box around them) but do not activate them.  Pressing ENTER at that
point does activate the button, but clicking has no effect.  If GIMP loses focus
(I click the desktop or some other window), then the next button click within
GIMP works fine again, but then subsequent ones do not.

I run GIMP on two separate Windows PCs, and this is only happening on one of
them.  On the affected PC, I've uninstalled and reinstalled GIMP, rebooted, even
completely deleted the .gimp-2.8 directory in case there was some odd, lingering
corruption.  I even reverted back to GIMP 2.6.12 and it doesn't work there now
either.  So it would seem to be a more generic issue and not necessarily
directly related to GIMP.  But I  use this PC extensively for many tasks
throughout the day, and nothing else seems to be affected.

I guess I'm hoping someone here has experienced something similar or at least
has some ideas of what to try next.  Thanks for any feedback you can provide.

kzibart (via
gimp-user-list mailing list

Reply via email to