On Sun, Dec 11, 2005 at 10:41:47AM -0800, [EMAIL PROTECTED] wrote:
> On Sun, Dec 11, 2005 at 02:25:07AM -0800, Manish Singh wrote:
> 
> > A gimp-devel package *must* have a dependency that either directly or
> > indirectly pulls in glib-devel. If it doesn't, the package's dependency
> > specification is broken.
> 
> > SuSE has a history of being shoddy in this regard, other examples that
> > have affected gimp are glib-devel not requiring pkg-config, aalib being
> > linked against slang but not requiring slang-devel, and a few more I
> > can't recall off the top of my head right now.
> 
> For Open SuSE 10:
> 
> # rpm -q -R -p gimp-devel-2.2.8-6.i586.rpm
> gtk2-devel
> glib2-devel
> glibc-devel
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> rpmlib(CompressedFileNames) <= 3.0.4-1
> rpmlib(PayloadIsBzip2) <= 3.0.5-1
> 
> # rpm -q -R -p glib2-devel-2.8.1-3.i586.rpm
> glib2 = 2.8.1
> pkgconfig
> glibc-devel
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> rpmlib(CompressedFileNames) <= 3.0.4-1
> /bin/sh
> /usr/bin/perl
> libc.so.6
> libc.so.6(GLIBC_2.0)
> libc.so.6(GLIBC_2.1)
> libglib-2.0.so.0
> libgobject-2.0.so.0
> rpmlib(PayloadIsBzip2) <= 3.0.5-1
> 
> Are you saying the above is incorrect? How so?

That looks fine with regards to -devel package dependencies. The
original person who had the problem is using SuSE 9.2, which obviously
is missing some of the above.

However, gimp-devel should also depend on gimp itself, so yes, the above
has missing dependencies.

-Yosh
_______________________________________________
Gimp-user mailing list
Gimp-user@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-user

Reply via email to