Ok so I have tried to do this  *plink x...@github.com "git --version" * but
I have received this error :

*C:\Users\XXX>plink x...@github.com "git --version"
FATAL ERROR: Disconnected: No supported authentication methods available
(server sent: publickey)*
When I set my *GIT_SSH* to *C:\Putty\ * (where I have plink.exe) (I have
also added  *C:\Putty\*   to *PATH )  *then I get this on *git clone  *
*$ GIT_TRACE=1 git clone g...@github.com:XXX/AffableBean
trace: built-in: git 'clone' 'g...@github.com:XXX/AffableBean'
Cloning into 'AffableBean'...
trace: run_command: 'C:\Putty\' 'g...@github.com' 'git-upload-pack '\''XXX
error: cannot spawn C:\Putty\: No such file or directory
fatal: unable to fork*

What other information should I provide ?

2012/6/13 Konstantin Khomoutov <flatw...@users.sourceforge.net>

> On Wed, 13 Jun 2012 03:49:23 -0700 (PDT)
> Patryk Małek <malekpat...@gmail.com> wrote:
> > I have a problem with github - namely I cannot push changes to remote
> > server i.e. github because I always get "cannot spawn ssh/plink "etc
> > etc errors . I am using Win7 (git installation with separate bash )
> > and I have been already trying many things with e.g. environment
> > variables ( GIT_SSH ) . I have even created a topic on
> > www.stackoverflow.com but noone was able to help me.
> > http://stackoverflow.com/questions/10574267/cannot-
> spawn-ssh-when-connecting-to-github-but-ssh-t-gitgithub-com-works
> >
> >
> > I have used ssh installed with git or e.g. plink from putty's package
> > but none of these worked . I have tried setting GIT_SSH to
> > executables and then to directories with executables but none of
> > these worked either. I know that there is an issue with directories
> > with spaces so I placed exes to C:\Putty\ but still no go.
> >
> >
> > Please help me because I really want to try Git but I cannot even
> > start since I have this problem.
> Cc-ing to the msysgit mailing list as this question most probably
> belongs there.
> Please provide exact description of your setup, what commands you run
> and what output they provide (copy and paste exactly). Better run the
> commands with GIT_TRACE environment variable set to "1" beforehand
> to produce verbose output.
> Note that your post is too inconstructive as it sounds like "I've tried
> a number of different combinations of different settings, none worked".
> Working with remote repos works for many people both with packaged
> OpenSSH client and with plink.exe from PuTTY, so try sticking to one
> solution and let's start from there.
> For instance, try sticking with PuTTY, verify the GIT_SSH environment
> variable is correctly set (to the full path to plink.exe, possibly
> double-quoted if PuTTY is installed under %ProgramFiles%),
> then verify plink.exe works for you outside or Git by running something
> like
> plink.exe you@git.server "git --version"
> Then re-try with Git, post what you run and what output you get.
>  Provide detailed info about your OS.

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to