Hello again,

A lot of time passed since my last e-mail but I have been trying some
different approaches to this problem but ... none worked. I have tried as
you suggested to go with *Github for Windows* which actually worked - but
it's not a go for me since I need this now for my work project where we
have a Git repo on our own server.

All the rest of the options have failed for me. I Have tried setting the *
GIT_SSH * to both *C:\Putty\plink.exe*  or leaving it as it was after the
install with *openssh*'s path(+exe name) but none worked - I still get *"cannot
spawn"* error.

I have also tried
http://blog.tfnico.com/2012/04/my-git-setup-on-windows.html  and
https://help.github.com/articles/set-up-git#platform-windows  but still the

I have reinstalled Git at least 50 times already trying different options,
clearing it's environmental variables and directories at the same time.

Why is this not working for me ?!

2012/6/13 Konstantin Khomoutov <flatw...@users.sourceforge.net>

> On Wed, 13 Jun 2012 14:30:27 +0200
> Patryk Małek <malekpat...@gmail.com> wrote:
> > Ok so I have tried to do this  *plink x...@github.com "git --version"
> > * but I have received this error :
> >
> > *C:\Users\XXX>plink x...@github.com "git --version"
> > FATAL ERROR: Disconnected: No supported authentication methods
> > available (server sent: publickey)*
> This means github only supports public-key-based authentication
> (the SSH protocol specifies at least three other, including a
> widely-known password-based).  Since you did not add your github key to
> your SSH key agent (pageant.exe from PuTTY), plink saw no usable
> key and hence failed to authenticate you.
> I somehow feel this will be the next obstacle you will run into
> so after you fix GIT_SSH (we'll get to that in a moment), be sure
> to read [1] which deals with generating and using SSH keys via PuTTY and
> [2] which deals with associating those keys with your github account.
> > When I set my *GIT_SSH* to *C:\Putty\ * (where I have plink.exe) (I
> > have also added  *C:\Putty\*   to *PATH )  *then I get this on *git
> > clone  * *
> > *
> > *$ GIT_TRACE=1 git clone g...@github.com:XXX/AffableBean
> > trace: built-in: git 'clone' 'g...@github.com:XXX/AffableBean'
> > Cloning into 'AffableBean'...
> > trace: run_command: 'C:\Putty\' 'g...@github.com' 'git-upload-pack
> > '\''XXX /AffableBean'\'''
> > error: cannot spawn C:\Putty\: No such file or directory
> > fatal: unable to fork*
> Well, Git precisely tells you what happened: it failed to execute
> "C:\Putty\".  Does attempt to execute a directory appear to be OK to
> you?  It shouldn't.  As I've told you in my previous response, the
> GIT_SSH environment variable has to be set to the full pathname of the
> plink.exe binary which is (probably) "C:\Putty\plink.exe" in your
> particular case.
> > What other information should I provide ?
> That's already enough.
> 1. http://nathanj.github.com/gitguide/tour.html#pushing
> 2. https://help.github.com/articles/generating-ssh-keys


Patryk Małek

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to