> Ingo Molnar [Thu, 21 Apr 2005]:
 > * Olivier Andrieu <[EMAIL PROTECTED]> wrote:
 > > There, here's a tarball :
 > >   http://oandrieu.nerim.net/monotone-viz/git-viz-0.1.tar.gz
 > i'm trying to build it under Fedora Core 4 (devel), and there are two 
 > problems:
 >  - the build scripts seem to assume that "." is in PATH (or that the 
 >    needed viz_style.ml/etc. scripts are in the PATH).

I'm not sure what's wrong here. It works fine for me when I run make
in the source directory and I don't have "." in PATH.

 > adding "." to the PATH worked around this issue, a number of files built 
 > fine, but then it hit the next problem:
 >  ocamlopt.opt  -I /usr/lib/ocaml/lablgtk2 -I glib -I crypto -pp  -c 
 > viz_style.ml
 >  sh: - : invalid option
 >  Usage:  sh [GNU long option] [option] ...
 >          sh [GNU long option] [option] script-file ...
 >  GNU long options:
 >  [...]
 >  Preprocessor error
 >  make: *** [viz_style.cmx] Error 2

That's probably because the configure script didn't find
camlp4. Camlp4 is a preprocessor for ocaml, it's needed for compiling
this file (viz_style.ml). Camlp4 is built with the ocaml compilers but
some package it separately. Try to find and install some ocaml-camlp4
(or camlp4) package and then re-run configure.

The configure script should signal an error when it doesn't find
camlp4, I'll change that.

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to