> Ingo Molnar [Thu, 21 Apr 2005]:
 > * Olivier Andrieu <[EMAIL PROTECTED]> wrote:
 > >  >  Preprocessor error
 > >  >  make: *** [viz_style.cmx] Error 2
 > > 
 > > That's probably because the configure script didn't find camlp4. 
 > > Camlp4 is a preprocessor for ocaml, it's needed for compiling this 
 > > file (viz_style.ml). Camlp4 is built with the ocaml compilers but some 
 > > package it separately. Try to find and install some ocaml-camlp4 (or 
 > > camlp4) package and then re-run configure.
 > ah, ok. I installed camlp4-3.08.3-1, and this also solved the other 
 > build problem as well that looked like to be a PATH problem.
 > when i run git-viz in a git-controlled directory, it seems to start up 
 > fine, but i get an error message: "Could not execute dot". Closing that 
 > window gives me the ability to do an 'Open', but git-viz does not seem 
 > to recognize any of my GIT repositories as such. (perhaps there's some 
 > GIT version dependency? I've got Linus' latest & greatest
 > installed.)

Yes, git-viz uses the `dot' program from the graphviz package (it's in
Fedora Extra too I believe).

 > > The configure script should signal an error when it doesn't find 
 > > camlp4, I'll change that.
 > fyi, it also didnt check for ocaml and lablgtk.

er, what's weird. Here's what I get :

| $ tar zxf git-viz-0.1.tar.gz
| $ cd git-viz-0.1
| $ ./configure
| checking for ocamlc... ocamlc
| OCaml version is 3.08.2
| OCaml library path is /usr/lib/ocaml
| checking for ocamlopt... ocamlopt

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to