Hi Tony, On Fri, Jan 30, 2015 at 7:08 PM, Tony Marston <tonymars...@hotmail.com> wrote:
> ""Pavel Kouril"" wrote in message > news:cab6yzuzymbaa5i3f9nsvebg2b7yjvo4ryvpy-eac78rsojx...@mail.gmail.com... > >> >> On Wed, Jan 28, 2015 at 1:17 PM, Michael Wallner <m...@php.net> wrote: >> >>> Hi, >>> >>> > <snip>> > > Hello, >> >> just one observation - would be the name of the classes and namespaces >> stay the same after merging? I personally find the lowercased >> namespace name kinda weird, given that most of code written in PHP >> I've seen is using CamelCase. >> > > Just because that most of the code YOU have seen uses CamelCase does not > mean that CamelCase is the "standard". I programmed in other languages for > over 20 years before I switched to PHP, and in those languages the standard > was snake_case. That is the standard I still use, and I will object most > strongly to the notion that I should change the habits of a lifetime just > to > suit the personal preferences of a junior programmer. By "junior" I mean > "years of experience", not "job title". > We have coding standard. >From the CODING_STANDARDS in source. 6. Method names follow the 'studlyCaps' (also referred to as 'bumpy case' or 'camel caps') naming convention, with care taken to minimize the letter count. The initial letter of the name is lowercase, and each letter that starts a new 'word' is capitalized:: Good: 'connect()' 'getData()' 'buildSomeWidget()' Bad: 'get_Data()' 'buildsomewidget' 'getI()' 7. Classes should be given descriptive names. Avoid using abbreviations where possible. Each word in the class name should start with a capital letter, without underscore delimiters (CamelCaps starting with a capital letter). The class name should be prefixed with the name of the 'parent set' (e.g. the name of the extension):: Good: 'Curl' 'FooBar' Bad: 'foobar' 'foo_bar' Regards, -- Yasuo Ohgaki yohg...@ohgaki.net