"Yasuo Ohgaki" wrote in message
news:caga2bxzgljrp6i2vdnkdga8dw7nothc9ie17tst40kpbbha...@mail.gmail.com...
Hi Tony,
On Fri, Jan 30, 2015 at 7:08 PM, Tony Marston <tonymars...@hotmail.com>
wrote:
""Pavel Kouril"" wrote in message
news:cab6yzuzymbaa5i3f9nsvebg2b7yjvo4ryvpy-eac78rsojx...@mail.gmail.com...
On Wed, Jan 28, 2015 at 1:17 PM, Michael Wallner <m...@php.net> wrote:
<snip>>
Hello,
just one observation - would be the name of the classes and namespaces
stay the same after merging? I personally find the lowercased
namespace name kinda weird, given that most of code written in PHP
I've seen is using CamelCase.
Just because that most of the code YOU have seen uses CamelCase does not
mean that CamelCase is the "standard". I programmed in other languages
for
over 20 years before I switched to PHP, and in those languages the
standard
was snake_case. That is the standard I still use, and I will object most
strongly to the notion that I should change the habits of a lifetime just
to
suit the personal preferences of a junior programmer. By "junior" I mean
"years of experience", not "job title".
We have coding standard.
From the CODING_STANDARDS in source.
6. Method names follow the 'studlyCaps' (also referred to as 'bumpy case'
or 'camel caps') naming convention
<snip>>
7. Classes should be given descriptive names. Avoid using abbreviations
where possible. Each word in the class name should start with a
capital
letter, without underscore delimiters (CamelCaps starting with a
capital
letter). The class name should be prefixed with the name of the
'parent
set' (e.g. the name of the extension)::
<<snip>>
If you are talking about coding standards which apply to PHP core then that
is one thing, but trying to enforce those standards in userland code would
be completely unacceptable.
--
Tony Marston
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php