[ 
https://issues.apache.org/jira/browse/HBASE-15893?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15408739#comment-15408739
 ] 

Enis Soztutar commented on HBASE-15893:
---------------------------------------

bq. Instead of returning integer 0 for suceess and otherwise, have used an enum 
which can be used for indicating error codes
But we are never returning error codes, we always throw exception, no? 
bq. We have an API GetFamily(); NumFamilies() was added as there is a similar 
method in Java client
GetFamily() should be named GetFamilyMap(). NumFamilies does not seem too 
useful, we can just remove it. 
bq. For returned results the reference is returned so that we can use method 
chaining. (get.SetMaxVersions(4).SetCacheBlocks(false))
I was referring to return values like this: 
{code}
+const bool & Get::GetCacheBlocks() const {
{code}

> Get object
> ----------
>
>                 Key: HBASE-15893
>                 URL: https://issues.apache.org/jira/browse/HBASE-15893
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Sudeep Sunthankar
>            Assignee: Sudeep Sunthankar
>         Attachments: HBASE-15893.HBASE-14850.v1.patch, 
> HBASE-15893.HBASE-14850.v2.patch
>
>
> Patch for creating Get objects.  Get objects can be passed to the Table 
> implementation to fetch results for a given row. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to