Hi Guys,
I don't think this is causing problems with many of our programs, however after my discussion with Kyle on Jallist, it seems we should not use "_" as the first character for any identifiers. My usb_msd.jal library does not work because of this, even though I did not use variables starting with "_temp". Per Kyle's suggestion, it seems we should go through all our libs to rename variables. To keep it simple, I suggest moving all underscore at the beginning of variable names to the end of the variable name, or rename the variable all together if you wish. Buildbot is not working at the moment. Please continue to commit. We can leave this issue for later when buildbot is back up again. Our Jallib style guide suggests to use the underscore character. "Names of other global entities (not supposed being used by application programs) should use this prefix and use an additional underscore at the beginning." https://code.google.com/p/jallib/wiki/JallibStyleGuide Rob, do you think we need to update all device files? Do you guys think we should proceed with this change to our libs? >> Would you suggest renaming of all variables and procedures that start with "_" in my projects, or only those that start with _temp ? What others can cause an issue? >>>> yes, I suggest avoiding any identifiers starting with '_'. Some are created in the PIC library for internal functions, the FOR statement might create one, etc. I *think* _temp is the only one that does special processing. -- You received this message because you are subscribed to the Google Groups "jallib" group. To unsubscribe from this group and stop receiving emails from it, send an email to [email protected]. To post to this group, send email to [email protected]. Visit this group at http://groups.google.com/group/jallib. For more options, visit https://groups.google.com/d/optout.
