[ https://issues.apache.org/jira/browse/LUCENE-1614?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12704633#action_12704633 ]
Shai Erera commented on LUCENE-1614: ------------------------------------ bq. I think after check(N) is called, one cannot call doc() I think one cannot even call next(). If check(8) returns true, then you know that doc() will return 8 (otherwise it's a bug?). But if it returns false, it might be in 10 already, so calling next() will move it to 11 or something. So to be on the safe side, we should document that doc()'s result is unspecified if check() returns false, and next() is not recommended in that case, but skipTo() or check(M). bq. Though, in order to run perf tests, we'd need the AND/OR scorers to efficiently implement check(). I plan to, as much as I can, efficiently implement nextDoc() and advance() in all Scorers/DISIs. So I can include check() in the list as well. Or .. maybe you know something I don't and you think this should deserve its own issue? > Add next() and skipTo() variants to DocIdSetIterator that return the current > doc, instead of boolean > ---------------------------------------------------------------------------------------------------- > > Key: LUCENE-1614 > URL: https://issues.apache.org/jira/browse/LUCENE-1614 > Project: Lucene - Java > Issue Type: Improvement > Components: Search > Reporter: Shai Erera > Fix For: 2.9 > > > See > http://www.nabble.com/Another-possible-optimization---now-in-DocIdSetIterator-p23223319.html > for the full discussion. The basic idea is to add variants to those two > methods that return the current doc they are at, to save successive calls to > doc(). If there are no more docs, return -1. A summary of what was discussed > so far: > # Deprecate those two methods. > # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI > (calls next() and skipTo() respectively, and will be changed to abstract in > 3.0). > #* I actually would like to propose an alternative to the names: advance() > and advance(int) - the first advances by one, the second advances to target. > # Wherever these are used, do something like '(doc = advance()) >= 0' instead > of comparing to -1 for improved performance. > I will post a patch shortly -- This message is automatically generated by JIRA. - You can reply to this email to add a comment to the issue online. --------------------------------------------------------------------- To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org For additional commands, e-mail: java-dev-h...@lucene.apache.org