On Jun 18, 2013, at 11:28 PM, Mandy Chung <[email protected]> wrote:
> On 6/18/2013 11:12 PM, Jeroen Frijters wrote:
>> Hi Mandy,
>>
>> Part of the exception message is a bit confusing:
>>
>> "Update code properly using this method to allow the code"
>
> Thanks Jeroen. I should strike out "using this method". What about:
> "Update code properly to allow the code to work on future 7 update
> releases."
I agree and suggest tightening it a little more:
s/allow the code to work on/function properly on/
I would prefer that your test case not duplicate logic verbatim from the source
code.
Consider rewriting as a sequence that responds directly to the specified inputs:
String s = System.getProperty("jdk.reflect.allowGetCallerClass");
boolean allowed;
if (s == null || s.equals("false")) allowed = false;
else if (s.equals("") || s.equals("true")) allowed = true;
else throw new ...
You can count me as a reviewer.
— John