On 3/30/12 4:50 AM, Diego Biurrun wrote:
On Fri, Mar 30, 2012 at 12:45:10PM +0100, Måns Rullgård wrote:
Diego Biurrun<[email protected]> writes:
Also drop the now unnecessary ff_h264_ prefix from its name.
---
--- a/libavcodec/h264.c
+++ b/libavcodec/h264.c
@@ -4559,7 +4559,7 @@ av_cold void ff_h264_free_context(H264Context *h)
-av_cold int ff_h264_decode_end(AVCodecContext *avctx)
+static av_cold int decode_end(AVCodecContext *avctx)
Please keep the h264 prefix on the name. Having somewhat unique
function names helps if they show up in a stack trace or someone wants
to set a debugger breakpoint.
The problem is that we don't do this consistently anywhere, much less
in this file. Keeping the prefix on a single function looks like an
exercise in futility to me.
I try to avoid anonymous functions and I change them every time I could,
please go in that direction.
lu
_______________________________________________
libav-devel mailing list
[email protected]
https://lists.libav.org/mailman/listinfo/libav-devel