Diego Biurrun <[email protected]> writes:

> Also drop the now unnecessary ff_h264_ prefix from its name.
> ---
>  libavcodec/h264.c |    6 +++---
>  libavcodec/h264.h |    1 -
>  2 files changed, 3 insertions(+), 4 deletions(-)
>
> diff --git a/libavcodec/h264.c b/libavcodec/h264.c
> index d49857e..81f8ad0 100644
> --- a/libavcodec/h264.c
> +++ b/libavcodec/h264.c
> @@ -4559,7 +4559,7 @@ av_cold void ff_h264_free_context(H264Context *h)
>          av_freep(h->pps_buffers + i);
>  }
>
> -av_cold int ff_h264_decode_end(AVCodecContext *avctx)
> +static av_cold int decode_end(AVCodecContext *avctx)

Please keep the h264 prefix on the name.  Having somewhat unique
function names helps if they show up in a stack trace or someone wants
to set a debugger breakpoint.

-- 
Måns Rullgård
[email protected]
_______________________________________________
libav-devel mailing list
[email protected]
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to