Solved, sort of...
Well I can now call elyxer from Lyx.
Here is the black magic that allowed this (I do not understand at all why it
was not working before and why it works now ;-)  ):

I have tried several reconfigures+quits without any success.
Then I have decided to duplicate your configuration. I have moved elyxer.py
in Program Files/elyxer and changed the path in Lyx in conformity with this.
Then reconfigure and restart.

First trial Lyx has tried to run elyxer (instead of htlatex) and this was
already a success but it could not find elyxer since I have moved it from
the scripts folder. I have copied it back to this folder (without changing
my path string) and bingo! I have a beatiful HTML page.

Elyxer's result is really very nice out of the box. Thank you very much Alex
for this tool.

My preferences file now reads:

\path_prefix "C:/Program Files/LyX16/bin;C:/Program
Files/LyX16/python;C:/TeXLive2008/bin/win32;C:/Program
Files/LyX16/ghostscript/bin;C:/Program Files/LyX16/imagemagick;C:/Program
Files/elyxer"

and

\converter "lyx" "html" "python $$s/scripts/elyxer.py $$i $$o" ""

I am happy that it works now but I would be happy to understand why ;-)

Thanks to all (to Olivier and Alex in particular) for your help.

Best regards,

Murat

2009/6/14 Olivier Ripoll <durocortorum73-gm...@yahoo.fr>

> Murat Yildizoglu wrote:
>
>> Thank you for all your help. In fact, I have also put the path to Lyx's
>> script folder (where elyxer resides) to the path box in the preferences of
>> Lyx in the same time as the configuration of the Lyx->HTML conversion
>> command  box. If I read well Olivier's message, there is not any
>> contradiction between these two boxes. I have also observed that during
>> the
>> first configuration,  Lyx->HTML command has disappeared from the
>> conversion
>> options and I had to add it by hand.
>>
>
> I think I remember seeing that once.
>
>  I have erased this command and done a reconfigure and here is what I see
>> in
>> my preferences file (Lyx continues to run latex and htlatex):
>>
>
> Have you tried to reconfigure twice (reconf, quit, restart, reconf, quit,
> restart) as I explained in my earlier post ?
>
>  Concerning the path (elyxer.py is in the last folder of the path)
>>
>> \path_prefix "C:/Program Files/LyX16/bin;C:/Program
>> Files/LyX16/python;C:/TeXLive2008/bin/win32;C:/Program
>> Files/LyX16/ghostscript/bin;C:/Program Files/LyX16/imagemagick; C:/Program
>> Files/LyX16/Resources/scripts"
>>
>
> Mine is:
> \path_prefix "C:/Program Files/LyX 1.6.3/bin;c:/program files/miktex
> 2.7/miktex/bin;C:/Program Files/gs/gs8.64/bin;C:/Program
> Files/ImageMagick-6.4.5-Q16;C:/Program Files/Ghostgum/gsview;;C:/Program
> Files/PSPad editor;C:/Program Files/GIMP-2.0/bin;C:/Program
> Files/Inkscape;C:/Program Files/LyX 1.6.3/etc/Metafile2eps;C:/Program
> Files/elyxer"
>
>  Concerning the conversion:
>>
>> \converter "lyx" "html" "python $$s/scripts/elyxer.py $$i $$o" ""
>>
>
> I have the same line.
>
>
>> And this is the only element about Lyx->HTML conversion
>>
>> Do you see anything strange in these items? What am I doing wrong?
>>
>
> [...]
>
> Best regards,
>
> Olivier.
>
>


-- 
Prof. Murat Yildizoglu
Université Paul Cézanne (Aix-Marseille 3)
GREQAM (UMR CNRS 6579)
Centre de la Vieille Charité
2, rue de la Charité
13236 Marseille cedex 02

Bureau 320
Tel : +33 4 91 14 07 27 (standard)
Tel : +33 4 91 14 07 70 (secrétariat)
Tel : +33 4 91 14 07 47 (bureau)
Fax : +33 4 91 90 02 27

e-mail: murat.yildizo...@univ-cezanne.fr
www : http://www.vcharite.univ-mrs.fr/PP/yildi/index.html
http://www.twitter.com/yildizoglu
______________________________________________

Reply via email to