Do you have an issue of Perl versions here -- 5.8.6 having been upgraded to 5.8.8? I never solved the issue myself; ultimately I just stayed with the OS X standard or 5.8.8 and removed MacPorts. Would love for some clued in explanations ;)

I can not remember the details of what I was trying but I guess it was less important then having a fully 'aware' Perl installation.


On 7 Sep, 2008, at 10:09, Vic Norton wrote:

I want to access https URLs on the web via LPW. To do this I need Crypt::SSLeay.

I have not been able to install Crypt::SSLeay directly so I tried MacPorts. Everything seemed to go fine, but LPW::UserAgent says Crypt::SSLeay is not installed:

501 Protocol scheme 'https' is not supported (Crypt::SSLeay not installed)

I can see Crypt::SSLeay in two places:
/opt/local/lib/perl5/vendor_perl/5.8.8/darwin-2level/auto/Crypt/ SSLeay
Right now I've got
PERL5LIB=/Library/Perl/5.8.6:/opt/local/lib/perl5/vendor_perl/ 5.8.8/darwin-2level LPW insists Crypt::SSLeay is not installed. I've tried various other PER5LIB strings that seemed appropriate. None worked.

How do I get Perl to recognize a Perl module ported via MacPorts? In particular, how do I get LPW::UserAgent to see Crypt::SSLeay?

Thanks for any advice you van give me.



Reply via email to