> Am 22.09.2016 um 00:23 schrieb Theo de Raadt:
> >> But on that alix box, nothing seems to arrive at the serial line. I
> >> tried all of these (the <x> were in 0 t o5):
> >>
> >> # cu -d -l ttyC<x> -s
> >> 9600
> >>
> >> Connected to /dev/ttyC<x> (speed 9600)
> > Well, because that is one of the virtual console / screen
> > device.  You want to use tty00.
> Thank you. Now I get this error:
> # cu -d -l tty00 -s 9600
> cu: open("/dev/tty00"): Device not configured
Use cua00

Look -- did you read the manual page?

     -l line
           Specify the line to use.  Either of the forms like cua00 or
           /dev/cua00 are permitted.  The default is /dev/cua00.  See cua(4)
           for information on terminal devices.  Users in group ``dialer'' are
           permitted to use cua(4) devices by default.

Did you then read follow the breadcrumps to read cua(4)


> I didn't find how to configure this/a device. Tried /etc/remote,
> /etc/ttys, many man pages, Absolute OpenBSD, read about line disciplines
> (but didn't find hot to configure them), etc. Also, from 5.8 on tip is
> not there any more, guess it was merged with cu or so. Or are there
> (more) framework change with doc lagging behind?
> Anyway -- any hints?
> If I understood ttys correctly, I can attach my serial logger software
> (instead of getty) directly to tty00 (once I know how to configure it),
> so that when the box boots, it automatically starts logging, and if the
> process disappears, it restarts it. Right?

It seems you did all that, but didn't read the manual pages.

In fact, what you want is entirely the defaults:

   # cu

Reply via email to