Am 22.09.2016 um 04:00 schrieb Theo de Raadt:
>> Am 22.09.2016 um 00:23 schrieb Theo de Raadt:
>>>> But on that alix box, nothing seems to arrive at the serial line. I
>>>> tried all of these (the <x> were in 0 t o5):
>>>>
>>>> # cu -d -l ttyC<x> -s
>>>> 9600
>>>>
>>>> Connected to /dev/ttyC<x> (speed 9600)
>>> Well, because that is one of the virtual console / screen
>>> device.  You want to use tty00.
>> Thank you. Now I get this error:
>>
>> # cu -d -l tty00 -s 9600
>> cu: open("/dev/tty00"): Device not configured
>
> Use cua00
>
> Look -- did you read the manual page?
>
>
>      -l line
>            Specify the line to use.  Either of the forms like cua00 or
>            /dev/cua00 are permitted.  The default is /dev/cua00.  See
cua(4)
>            for information on terminal devices.  Users in group ``dialer''
are
>            permitted to use cua(4) devices by default.
>
>
> Did you then read follow the breadcrumps to read cua(4)
>
> ?
>
>> I didn't find how to configure this/a device. Tried /etc/remote,
>> /etc/ttys, many man pages, Absolute OpenBSD, read about line disciplines
>> (but didn't find hot to configure them), etc. Also, from 5.8 on tip is
>> not there any more, guess it was merged with cu or so. Or are there
>> (more) framework change with doc lagging behind?
>> Anyway -- any hints?
>>
>> If I understood ttys correctly, I can attach my serial logger software
>> (instead of getty) directly to tty00 (once I know how to configure it),
>> so that when the box boots, it automatically starts logging, and if the
>> process disappears, it restarts it. Right?
> It seems you did all that, but didn't read the manual pages.
Oh yes, I did. That's what I started with (but didn't tell so in my
first mail).
Then you sent me on the tty00 way and I tried to figure that out (and
learned certain things, like that tty and cua are kind of pairs for
rx/tx, but didn't get into the detailed details how it's attached where
internally, etc.), but to no avail.
> In fact, what you want is entirely the defaults:
>
>    # cu
Sure, it look's like a very standard thing to do, but:

# cu -d -l cua00 -s 9600
cu: open("/dev/cua00"): Device not configured
# cu
cu: open("/dev/cua00"): Device not configured

So I wonder if the device is recognized at all by the kernel when it
starts. Doesn't look like so, unless it's implied with certain devices.
(The dmesg is in my first post.)

Extract of my /etc/ttys (changed it a bit to try out tty00 without getty
getting in the way):

# name  getty                           type    status          comments
#
console "/usr/libexec/getty std.9600"   vt220   off secure
ttyC0   "/usr/libexec/getty std.9600"   vt220   on  secure
ttyC1   "/usr/libexec/getty std.9600"   vt220   on  secure
ttyC2   "/usr/libexec/getty std.9600"   vt220   on  secure
ttyC3   "/usr/libexec/getty std.9600"   vt220   on  secure
ttyC4   "/usr/libexec/getty std.9600"   vt220   off secure
ttyC5   "/usr/libexec/getty std.9600"   vt220   on  secure
ttyC6   "/usr/libexec/getty std.9600"   vt220   off secure
ttyC7   "/usr/libexec/getty std.9600"   vt220   off secure
ttyC8   "/usr/libexec/getty std.9600"   vt220   off secure
ttyC9   "/usr/libexec/getty std.9600"   vt220   off secure
ttyCa   "/usr/libexec/getty std.9600"   vt220   off secure
ttyCb   "/usr/libexec/getty std.9600"   vt220   off secure
#tty00  "/usr/libexec/getty std.9600"   unknown off
tty00   none                            unknown off
tty01   "/usr/libexec/getty std.9600"   unknown off
tty02   "/usr/libexec/getty std.9600"   unknown off
tty03   "/usr/libexec/getty std.9600"   unknown off
tty04   "/usr/libexec/getty std.9600"   unknown off

I also tried console:

# cu -d -l console -s 9600
Connected to /dev/console (speed 9600)

Seems configured at least -- but no data arrives. So still something is
missing.
Maybe some BIOS quirk, who knows.
Maybe someone on this list had a similar problem?

This is a very fresh install, I didn't update but reinstall completely.

Peer


--
Peer Janssen - p...@pjk.de

Reply via email to