luth2 commented on code in PR #45823: URL: https://github.com/apache/superset/pull/45823#discussion_r4431345390
########## docs/admin_docs/installation/pypi.mdx: ########## @@ -15,6 +15,75 @@ import useBaseUrl from '@docusaurus/useBaseUrl'; This page describes how to install Superset using the `apache_superset` package [published on PyPI](https://pypi.org/project/apache_superset/). +## Python Compatibility + +The minimum Python version is 3.11. The Python version classifiers in +[pyproject.toml](https://github.com/apache/superset/blob/master/pyproject.toml) +list the officially supported versions; the open-ended `requires-python` lower +bound does not certify every newer interpreter. + +The source checkout includes experimental Python 3.15 compatibility. Its package +requirements select NumPy `>=2.5.4,<2.6` and pandas `>=3.1.0,<3.2` on Python 3.15 +and newer. Python 3.11 through 3.14 retain NumPy `>=1.23.5,<2.5` and pandas +`>=2.3.3,<2.4`; the minimum Python version has not changed. These source changes Review Comment: Agreed; this became stale after merging the upstream pandas-3 baseline. Fixed in 6b78fdb989: the documented Python 3.11-3.14 pandas range is now >=3.0.6,<3.1, matching pyproject.toml and the lockfile baseline. The experimental Python 3.15 range remains >=3.1.0,<3.2. -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected] --------------------------------------------------------------------- To unsubscribe, e-mail: [email protected] For additional commands, e-mail: [email protected]
