I also tried the following in my gold/build server to check the
difference in behaviour of the iscsistart n iscsiadm .. and noticed
the following:

On Apr 30, 12:29 pm, Mike Christie <[EMAIL PROTECTED]> wrote:

> iscsistart was created, becuase the db used to require other fun libs
> and throwing them into the initrd was a pain for many distros, and so
> you could just pass in the value you want to use by doing

the reason why I tried to use iscsiadm in lieu of iscsistart, was
because in my golden build server, I error'ed out when I tried to
connect to my target using iscsistart; however, with iscsiadmn I can

My server is:  Ubuntu 8.x (Hardy) ...

1.  In attempt to troubleshoot, I do not have the iscsid daemon
running so, while testing to connect via iscistart, I try the

a.  load all necessary modules - modules - and they load fine.
b.  run the iscsistart CLI:
 ./iscsistart -i iqn.1993-08.org.debian:01:abc2b6545e4 -t iqn.
2008-04.com.mycompany:storage.ubuntu8_x86_test -g 1 -a
iscsistart: transport class version 2.0-724. iscsid version 2.0-869
iscsistart: version 2.0-869
iscsistart: received iferror -22
iscsistart: can't create connection (115)
iscsistart: received iferror -22
iscsistart: can not safely destroy session 0
iscsistart: received iferror -22
iscsistart: can't bind conn 0:0 to session 0, retcode 1 (115)

the machine is just in a hang state .. any ideas??
the iscsid daemon still runs:
sbin# ps -elf | grep iscsi
1 S root     22031     1  0  80   0 -  1007 -      13:49 ?
00:00:00 ./iscsid
0 R root     22223 21108  0  80   0 -  1290 -      14:00 pts/2
00:00:00 grep iscsi

2.I tried to kill the iscid daemon and try the following:

a.  run the /etc/init.d/open-iscsi script - the iscsid daemon is up.
b.  I try to run iscsiadm:

 iscsiadm -m node -T iqn.
2008-04.com.mycompany:storage.ubuntu8_x86_test -p -l
iscsiadm: no records found!
[EMAIL PROTECTED]:/etc/init.d# iscsiadm -m node -T iqn.
2008-04.com.mycompany.ubuntu8_x86_test -p -o new
New iSCSI node [tcp:[hw=default,ip=,net_if=default,iscsi_if=default],3260,-1 iqn.
2008-04.com.mycompany:storage.ubuntu8_x86_test] added
[EMAIL PROTECTED]:/etc/init.d# iscsiadm -m node -T iqn.
2008-04.com.mycompany.ubuntu8_x86_test -p -l
Login session [iface: default, target: iqn.
2008-04.com.mycompany:storage.ubuntu8_x86_test, portal:,3260]
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/open-iscsi

Reply via email to