Don't exactly know how yet but i've managed to get rid of the session
that appeared to be hung. Possibly due to restarting iscsi and iscsid
with a config file where usernames and passwords were commented out.

Amazingly now i can use the iscsiadm interface as expected which it
refused to at first.

Selectively commenting the usernames en passwords in the iscsid.conf
file was key to the success for mounting the iscsi-target.


Joris

On 27 jul, 23:29, Mike Christie <micha...@cs.wisc.edu> wrote:
> On 07/24/2009 01:05 PM, Joris wrote:
>
> > Hi Mike,
>
> > In the meantime i've kind of got it to work but i feel like acting
> > blind.
>
> > I've not followed any of the steps i've found in the documentation
> > across the web.
>
> > Instead i've used
>
> > 1. iscsistart ....
>
> How did you run iscsistart?
>
> iscsistart is only used for boot in the initramfs. It does not have any
> error handling, so if you only use this and something like a switch dies
> then you are dead.
>
>
>
> > 2. partitioned the newly created device
>
> > mounted it and that's it
>
> > Now i wonder what's going on if this demands such an exception.
>
> > - - - requested output, credentials obfuscated ---
>
> > iscsiadm -m node -T mytarget -p 11.22.33.44
> > # BEGIN RECORD 2.0-868
> > node.name = mytarget
> > node.tpgt = -1
> > node.startup = manual
> > iface.hwaddress = default
> > iface.iscsi_ifacename = default
> > iface.net_ifacename = default
> > iface.transport_name = tcp
> > node.discovery_address =<empty>
> > node.discovery_port = 0
> > node.discovery_type = static
> > node.session.initial_cmdsn = 0
> > node.session.initial_login_retry_max = 2
> > node.session.cmds_max = 128
> > node.session.queue_depth = 32
> > node.session.auth.authmethod = CHAP
> > node.session.auth.username = myusername
> > node.session.auth.password = ********
> > node.session.auth.username_in = myusername
> > node.session.auth.password_in = ********
> > node.session.timeo.replacement_timeout = 120
> > node.session.err_timeo.abort_timeout = 15
> > node.session.err_timeo.lu_reset_timeout = 30
> > node.session.err_timeo.host_reset_timeout = 60
> > node.session.iscsi.FastAbort = Yes
> > node.session.iscsi.InitialR2T = Yes
> > node.session.iscsi.ImmediateData = Yes
> > node.session.iscsi.FirstBurstLength = 262144
> > node.session.iscsi.MaxBurstLength = 16776192
> > node.session.iscsi.DefaultTime2Retain = 0
> > node.session.iscsi.DefaultTime2Wait = 2
> > node.session.iscsi.MaxConnections = 1
> > node.session.iscsi.MaxOutstandingR2T = 1
> > node.session.iscsi.ERL = 0
> > node.conn[0].address = 11.22.33.44
> > node.conn[0].port = 3260
> > node.conn[0].startup = manual
> > node.conn[0].tcp.window_size = 524288
> > node.conn[0].tcp.type_of_service = 0
> > node.conn[0].timeo.logout_timeout = 15
> > node.conn[0].timeo.login_timeout = 15
> > node.conn[0].timeo.auth_timeout = 45
> > node.conn[0].timeo.noop_out_interval = 5
> > node.conn[0].timeo.noop_out_timeout = 5
> > node.conn[0].iscsi.MaxRecvDataSegmentLength = 131072
> > node.conn[0].iscsi.HeaderDigest = None,CRC32C
> > node.conn[0].iscsi.IFMarker = No
> > node.conn[0].iscsi.OFMarker = No
> > # END RECORD
>
> I would really try to find the root problem. Try the newer tools and
> give me the full error message in /var/log/messages.
>
> >> Could you send the entire error message?
>
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to 
open-iscsi+unsubscr...@googlegroups.com
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to