Hello Michael,

I see the board config files have the memory map proper as below, and the flash 
address is starting at 0x04000000. I tried this location and from 0x0 also. But 
I get the same error everywhere.

$_TARGETNAME configure -memorymap RW 0x00000000                   32 FLOPS      
         "Interrupt Vectors"
$_TARGETNAME configure -memorymap RO  0x00400000 0x00090000 ROM                 
$_TARGETNAME configure -memorymap RW 0x004A0000 0x00202000 RAM                  
$_TARGETNAME configure -memorymap RW 0x008A0000 0x00202000 RAM2                
$_TARGETNAME configure -memorymap RW 0x14000000 0x04000000 SFLASH              
$_TARGETNAME configure -memorymap RW 0x18000000 0x00027000 BACKPLANE      
"Backplane Registers"
$_TARGETNAME configure -memorymap RW 0x18100000 0x00032000 BACKPLANE2   
"Backplane Wrapper Registers"
$_TARGETNAME configure -memorymap RW 0x40000000 0x08000000 DDR                  
$_TARGETNAME configure -memorymap RW 0x001b0000 0x00090000 RAM                  

I am using WM-BAN-BM-33_EVB V3.0 board with olimex ARM-USB-TINY-H JTAG. That 
uses BCM4390x.cfg as the target config files.

I am able to program the binary to the board using the same connection using 
WICKED studio. Is there any chance the read is getting locked in this process?


From: Michael Schwingen [mailto:mich...@schwingen.org]
Sent: Wednesday, July 11, 2018 2:55 PM
To: openocd-devel@lists.sourceforge.net
Subject: Re: [OpenOCD-devel] [External] Re: Fwd: Image Dump Query

On 11.07.2018 10:54, N K, Athira wrote:
Hello Tommy,

Thank you for the quick response.

Actually I could get an example command

dump_image empty.bin 0x8D000 185

But I get a response

Ignoring read of non readable area - Request address: 0x8D000, Request size 
184. Bytes successfully read: 0
Where is your flash mapped to?
You have to use a start address that matches where your board and board config 
map the flash rom.

If 0xD8000 really is your flash start address (which sounds a bit odd, but I 
don't know anything about your board or target CPU), you need to modify the 
board config file to tell OpenOCD the correct flash location.

Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
OpenOCD-devel mailing list

Reply via email to