Hi Mathieu,

Basically that is exactly what I did and am getting an error.

CMake Error: File 
/usr/local/3rdparty/osgQt-git/packaging/ld.so.conf.d/openscenegraph.conf.in 
does not exist.
CMake Error at CMakeLists.txt:971 (CONFIGURE_FILE):
  configure_file Problem configuring file

The ld.so.conf.d directory does not exist within the packaging
directory on my system, its actually at: /etc/ld.so.conf.d

Currently ONLY the master branch 3.5.6 of osg is installed
on my system in its default location of /usr/local/lib64.

Here is my output of the entire process:

amx@ios:/usr/local/3rdparty> cd osgQt-git/
amx@ios:/usr/local/3rdparty/osgQt-git> mkdir BUILD
amx@ios:/usr/local/3rdparty/osgQt-git> cd BUILD/
amx@ios:/usr/local/3rdparty/osgQt-git/BUILD> cmake ..
-- The C compiler identification is GNU 4.8.3
-- The CXX compiler identification is GNU 4.8.3
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Found osgDB: /usr/local/lib64/libosgDB.so  
-- Found osgGA: /usr/local/lib64/libosgGA.so  
-- Found osgUtil: /usr/local/lib64/libosgUtil.so  
-- Found osgText: /usr/local/lib64/libosgText.so  
-- Found osgViewer: /usr/local/lib64/libosgViewer.so  
-- Found osgWidget: /usr/local/lib64/libosgWidget.so  
-- Found osg: /usr/local/lib64/libosg.so  
-- Found OpenThreads: /usr/local/lib64/libOpenThreads.so  
-- Found OpenSceneGraph: 
/usr/local/lib64/libosgDB.so;/usr/local/lib64/libosgGA.so;/usr/local/lib64/libosgUtil.so;/usr/local/lib64/libosgText.so;/usr/local/lib64/libosgViewer.so;/usr/local/lib64/libosgWidget.so;/usr/local/lib64/libosg.so;/usr/local/lib64/libOpenThreads.so
 (found suitable version "3.5.6", minimum required is "3.5.5") 
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so - 
found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Found OpenGL: /usr/lib64/libGL.so  

The build system is configured to install libraries to /usr/local/lib64
Your applications may not be able to find your installed libraries unless you:
    set your LD_LIBRARY_PATH (user specific) or
    update your ld.so configuration (system wide)
You have an ld.so.conf.d directory on your system, so if you wish to ensure that
applications find the installed osg libraries, system wide, you could install an
OpenSceneGraph specific ld.so configuration with:
    sudo make install_ld_conf

CMake Error: File 
/usr/local/3rdparty/osgQt-git/packaging/ld.so.conf.d/openscenegraph.conf.in 
does not exist.
CMake Error at CMakeLists.txt:971 (CONFIGURE_FILE):
  configure_file Problem configuring file


-- Configuring incomplete, errors occurred!
See also "/usr/local/3rdparty/osgQt-git/BUILD/CMakeFiles/CMakeOutput.log".
See also "/usr/local/3rdparty/osgQt-git/BUILD/CMakeFiles/CMakeError.log".


I was able to get past this error by running cmake-gui and
manually setting the build path, then clicked configure again 
and then finally was able to generate the makefile.  After that 
the osgQt project  built and installed ok on my system.
   
I currently have cmake 3.0.2 installed on my 64bit OpenSuSE 
13.2 Linux system that I am using  for this initial test in case
that affects any of this.

Thank you for your quick response..

Cheers,
Curtis

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=68981#68981





_______________________________________________
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

Reply via email to