Hello

Switching to a downloaded version of Qt (with the patch cory mentionned)
instead of using your package manager's Qt should do the trick.

Best,

Mathieu Westphal

On Tue, Feb 13, 2018 at 9:18 PM, Daniel Vogler <davog...@ethz.ch> wrote:

> Hi Cory, dear Artem,
>
> Thanks for the mails. Regarding the issue Cory sent.
>
>
> When doing the following:
>
> I moved libqgtk2.so (not libqgtk3.so in my case) from
> /opt/Qt/5.9.0/gcc_64/plugins/platformthemes
>
> and commented _all_ lines in /opt/Qt/5.9/gcc_64/lib/cmake/Qt5Gui/Qt5Gui_
> QGtk3ThemePlugin.cmake
>
> I then rebuild paraview (build succeeds) but when I try to execute
>
> user:~/software/paraview_bin$ ./bin/paraview
> libprotobuf FATAL /home/user/software/paraview/ThirdParty/protobuf/
> vtkprotobuf/src/google/protobuf/stubs/common.cc:62] This program requires
> version 2.6.0 of the Protocol Buffer runtime library, but the installed
> version is 2.3.0.  Please update your library.  If you compiled the program
> yourself, make sure that your headers are from the same version of Protocol
> Buffers as your link-time library.  (Version verification failed in
> "/build/mir-O8_xaj/mir-0.26.3+16.04.20170605/obj-x86_64-
> linux-gnu/src/protobuf/mir_protobuf.pb.cc".)
> Aborted
>
>
> I still have no success. I still have other version of Qt installed (also
> in opt) and did not uninstall "qt5-gtk-platformtheme" as suggested by Timo
> Oster in the thread you sent. Could any of this be the problem? I am
> hesitant to uninstall qt5-gtk-platformtheme as I'm not sure if that'll give
> me another conflict.
>
> Did I forget anything?
>
> Daniel
>
>
>
> On 13.02.2018 14:33, Cory Quammen wrote:
>
> Unfortunately, this is a known issue on Ubuntu 16.04.
>
> https://gitlab.kitware.com/paraview/paraview/issues/17751
>
>
> On Tue, Feb 13, 2018 at 2:29 PM, Artem Bodrin <art.bod...@gmail.com>
> wrote:
>
>> Hello, Daniel.
>> I have encountered the same trouble as you, Linux Mint (based on ubuntu
>> 16.04). I did not seek for a solution yet (no need for linux version right
>> now), but the answer is in the error output. If you inspect  the 3rd party
>> protobuf bundled with ParaView VTK submodule, then you can see that
>> original version used by VTK is 2.3.0
>> So I think, that during compilation it uses the system headers from
>> ubuntu (which is 2.6.1), but links on internal VTK protobuf library which
>> is 2.3.0.
>> My guessing is - remove dev package of protobuf from system and recompile
>> again, it might help.
>>
>>
>> > 13 февр. 2018 г., в 22:03, Daniel Vogler <davog...@ethz.ch> написал(а):
>> >
>> > Dear all,
>> >
>> > I am having trouble building Paraview 5.2.0 (This version or older is
>> required for a separate plug-in). Other installations of paraview (not
>> compiled from source) work fine.
>> >
>> > I run Ubuntu 16.04 LTS. I check out the paraview 5.2.0 release and
>> installed Qt5.6.3 (also tried 5.6 and 5.7 because I had trouble with Qt
>> during the paraview build earlier) in a separate directory. I have my
>> (empty) build directory paraview_bin and paraview 5.2.0 source in
>> /home/user/software/paraview_bin and /home/user/software/paraview
>> respectively.
>> >
>> > - export PATH=/opt/Qt/5.6.3/gcc_64/:$PATH
>> >
>> > - ccmake -D PARAVIEW_QT_VERSION:STRING=5 /path/to/paraview
>> >
>> > - BUILD_TESTING --> OFF
>> >
>> > - generation and make completes
>> >
>> > The build works fine, but when I try to execute I get a protobuf error
>> >
>> >
>> > user:~/software/paraview_bin$ ./bin/paraview
>> > libprotobuf FATAL /home/user/software/paraview/T
>> hirdParty/protobuf/vtkprotobuf/src/google/protobuf/stubs/common.cc:62]
>> > This program requires version 2.6.0 of the Protocol Buffer runtime
>> library, but the installed version is 2.3.0.
>> > Please update your library.
>> > If you compiled the program yourself, make sure that your headers are
>> from the same version of Protocol Buffers as your link-time library.
>> > (Version verification failed in "/build/mir-O8_xaj/mir-0.26.3+
>> 16.04.20170605/obj-x86_64-linux-gnu/src/protobuf/mir_protobuf.pb.cc".)
>> > Aborted
>> >
>> > although my protoc version seems fine
>> >
>> > user:~/software/paraview_bin$ protoc --version
>> > libprotoc 2.6.1
>> >
>> > I have tried uninstalling and reinstalling protoc and libprotobuf as
>> well as reinstalling Qt afterwards, but can not figure out this error.
>> >
>> > Any suggestions?
>> >
>> > Thanks a bunch,
>> >
>> > Dan
>> >
>>
>> _______________________________________________
>> Powered by www.kitware.com
>>
>> Visit other Kitware open-source projects at
>> http://www.kitware.com/opensource/opensource.html
>>
>> Please keep messages on-topic and check the ParaView Wiki at:
>> http://paraview.org/Wiki/ParaView
>>
>> Search the list archives at: http://markmail.org/search/?q=ParaView
>>
>> Follow this link to subscribe/unsubscribe:
>> https://public.kitware.com/mailman/listinfo/paraview
>>
>
>
>
> --
> Cory Quammen
> Staff R&D Engineer
> Kitware, Inc.
>
>
>
> _______________________________________________
> Powered by www.kitware.com
>
> Visit other Kitware open-source projects at http://www.kitware.com/
> opensource/opensource.html
>
> Please keep messages on-topic and check the ParaView Wiki at:
> http://paraview.org/Wiki/ParaView
>
> Search the list archives at: http://markmail.org/search/?q=ParaView
>
> Follow this link to subscribe/unsubscribe:
> https://public.kitware.com/mailman/listinfo/paraview
>
>
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at 
http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the ParaView Wiki at: 
http://paraview.org/Wiki/ParaView

Search the list archives at: http://markmail.org/search/?q=ParaView

Follow this link to subscribe/unsubscribe:
https://public.kitware.com/mailman/listinfo/paraview

Reply via email to