On 9/6/16 4:56 AM, Petr Jelinek wrote:
On 06/09/16 07:18, Abhijit Menon-Sen wrote:

Do we want something like this (easy to implement and document, perhaps
not especially convenient to use):

    recovery_target = 'xid'     # or 'time'/'name'/'lsn'/'immediate'
    recovery_target_xid = xxx?  # the only setting we care about now
    recovery_target_otherthings = parsed_but_ignored

Or something like this (a bit harder to implement):

    recovery_target = 'xid:xxx' # or 'time:xxx' etc.

Personally, I never liked the fact that we have several config variables
for this and then the last one is chosen (even when it was in
recovery.conf). We support one recovery_target at a time so it would
make sense to have single config option for it IMHO.

So +1 on the recovery_target = 'xid:xxx' idea.

I would rather not combine the type and target into a single field - how about having two fields:

recovery_target_type = 'xid|time|name|immediate'
recovery_target = 'value'

recovery_target would be ignored when recovery_target_type = 'immediate'.


Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to