Tom Lane wrote:
> "Dave Page" <> writes:
> > Aside from the fact that's a change to the API that we had settled on,
> > it doesn't solve the actual problem of needing a suitable name for a
> > function that returns the size of a table /or/ index. pg_relation_size()
> > or pg_table_size() can't be used for precisely the reason they were
> > rejected for that purpose in the first place.
> Rejected by whom?  pg_relation_size is an excellent choice for that.

We mostly tell people that table and relation are synonmous.  Though
there is a distinction, it seems error-prone to rely on that distinction
in the API.

  Bruce Momjian                        |               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---------------------------(end of broadcast)---------------------------
TIP 6: Have you searched our list archives?


Reply via email to