> -----Original Message-----
> From: Tom Lane [mailto:[EMAIL PROTECTED]
> Sent: 04 July 2005 14:54
> To: Dave Page
> Cc: Dawid Kuroczko; Andreas Pflug; Bruce Momjian;
> PostgreSQL-patches; PostgreSQL-development
> Subject: Re: [HACKERS] [PATCHES] Dbsize backend integration
> "Dave Page" <firstname.lastname@example.org> writes:
> > Aside from the fact that's a change to the API that we had
> settled on,
> > it doesn't solve the actual problem of needing a suitable name for a
> > function that returns the size of a table /or/ index.
> > or pg_table_size() can't be used for precisely the reason they were
> > rejected for that purpose in the first place.
> Rejected by whom? pg_relation_size is an excellent choice for that.
Bruce didn't like it
you seemed to object as well
Personally I'm beyond caring much now as the amount of time spent trying
to name these simple functions is wildly disproportionate the the effort
take to actually code them. I think we just need to agree there is no
perfect name and rely on the comments and docs to guide people. I think
the current names work OK, and Bruce and Dawid at least agree!
---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?