Andi Gutmans wrote:
> >bzerror returns an array containing the error string and error number.
> Maybe it should be error_info() then?

nerk? error seems sufficient to me...

> > > >>>Maybe errstr should be changed to errmsg ? (Did I say that
elsewhere ?
> >;-)
> > > >>>As the file extension is .bz2, maybe the prefix should be bz2_ as
> > > >>>(it's an algorithm, not a version right ?)
> >
> >bz2_ vs. bz_ ... this is a coin-toss decision.  We might run into an
> >extension in the future where bz is a good choice for the name, thought I
> >feel it is unlikely.
> >Personally, I don't *really* care - if it came to a heated discussion and
> >vote, I would go for bz2_... - just so that the no one could tell us "I
> >you so..." in the future. ;)
> Why not bzip2_?

Sure. :)

> It's very hard to draw the line but I tend to be in favor of readability
> vs. how many characters you need to type.

Alrighty, the disadvantage of using full names is typing speed... the
advantages are that the purpose of the function is clearer, there is no need
to attempt remember what the abbreviation for and non-native speakers can
use automated translation tools on the function names... so I guess that we
should go for readability.


PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to