A while ago someone just said that they could not see any more Zend API
changes coming. I said that moving extensions to PEAR could not happen
until Zend's API either stabilizes, or at least tries to be backwards
Obviously this won't be the case for a while yet. How do you propose
fixing this? Have people define a macro in their code stating which
version of the API they are using? As of now there are probably a few
extensions out there that will _only_ build with PHP 4.0.4 to 4.0.6 or
something like that, before which they _only_ built with 4.0.3, and now
they will be updated to require 4.0.7.
Zeev Suraski wrote:
> It should be fairly easy to support both codebases by just defining the
> right things depending on the API_NO. At any rate, whether we call it 4.1
> or 4.0.7 doesn't really matter. It had to be done, and would involve the
> same kind of issues regardless of the name.
> At 06:47 02/08/2001, Andrei Zmievski wrote:
> >On Thu, 02 Aug 2001, Andrei Zmievski wrote:
> > > I really wish all these TSRM changes were left for 4.1. There are just
> > > way too many functions affected and I guarantee you that all the
> > > standalone extensions will be broken because people will not expect such
> > > breakage from a point release.
> >Oh, as an example PHP-GTK v0.1 now has to require latest PHP CVS or
> >4.0.7 because of this. Not too good.
> >"The only true currency in this bankrupt world is what we share with each
> >other when we're uncool." -- Lester Bangs, from the film 'Almost Famous'
> Zeev Suraski <[EMAIL PROTECTED]>
> CTO & co-founder, Zend Technologies Ltd. http://www.zend.com/
> PHP Development Mailing List <http://www.php.net/>
> To unsubscribe, e-mail: [EMAIL PROTECTED]
> For additional commands, e-mail: [EMAIL PROTECTED]
> To contact the list administrators, e-mail: [EMAIL PROTECTED]
PHP Development Mailing List <http://www.php.net/>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]