Okies, FINALLY I think I have the reason (though not the solution as yet)

Marco, you were spot on, which I hadn't pursued properly, only looking at
the immediate parent directory permissions. In fact the whole ~vpopmail
structure down to the individual users directory has a VERY restrictive set
of permissions only the owner (vpopmail) can list read and write to any of
the directories leading down to the
~vpopmail/domains/some.email.domain/some.user/ etc.. etc... no group
permissions at ALL.

I have asked on the vpopmail list what the effect may be of re-setting group
list access (at least) to the structure may be as I dont want to break
anything on a running server... lol... so yep.. permissions it was indeed
(apparantly anyways), I reckon this is a proven case now, just got to work
out the solution as I can't setuid for a web enabled cgi to the vpopmail
user without getting stuck in suEXEC etc...

I dont know why the heck I hadnt tried just cat'ing the file.. lack of sleep
perhaps.. lol

Will let you know how it goes (if you are interested)

Regards, and thanks for all the help
David Cook

"Marco Tabini" <[EMAIL PROTECTED]> wrote in message
> Ok, that's a big step forward then. It's possible that your user does
> not have access to the directory tree where the file resides? Have you
> tried listing that directory and or opening the file (for example with
> cat) while using that file? If you can narrow it down to a permission
> problem (and, at this point, I think that's exactly where the problem
> is), that it should just be a matter of trying a few things out.

PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to