Status: Accepted
Owner: allain.lalonde
Labels: Type-Defect Priority-Low Toolkit-Piccolo2D.Java OpSys-All  
Component-Core Milestone-2.0 Usability

New issue 118 by allain.lalonde: PCanvas.getLayer() is misleading
http://code.google.com/p/piccolo2d/issues/detail?id=118

PCanvas.getLayer()'s name implies that only one layer can be attached to  
the canvas.
In reality though any number of layers can be attached to a PCanvas by  
attaching them to the PCanvas' camera.

So, a new user of the library would be limiting their options if they read  
the code and take it at face value.

I suggest deprecating getLayer and replacing it with getFirstLayer, or even  
removing getLayer completely since
it's just a bit of sugar that's equivalent to  
PCanvas.getCamera().getLayer(0).

I'm open to other suggestions, I just want to voice my concern regarding  
this.

--
You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:
http://code.google.com/hosting/settings

--~--~---------~--~----~------------~-------~--~----~
Piccolo2D Developers Group: http://groups.google.com/group/piccolo2d-dev?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to