On Fri, Apr 15, 2016 at 12:08:56PM -0400, cat stevens wrote:
> Hi! I am very interested in the idea and look of PilOS; however, I'm having
> some issues trying to get started with it. Can I ask about those here?

Sure! :)


> First, the command on the Wiki seems to have an issue, which I asked about
> here
> <http://unix.stackexchange.com/questions/276480/booting-a-raw-disk-image-in-qemu>
> -- it seems like it should be:
> 
> qemu-system-x86_64 -drive format=raw,file=x86-64.img

What I used for Qemu was

   $ qemu-system-x86_64  -m 4096  -smp 4  -ctrl-grab  -no-reboot  
pilos/x86-64.img

so it is similar to what you wrote in the above link, and it worked fine
for me.



> Even when I run that (apparently more correct) command, PilOS gives "READ
> ERROR 09" and hangs.

This is an error from the BIOS (Was this also Qemu?).


> I also tried booting my laptop from the raw disk image written to a USB. It
> said "Loading PilOS", then printed "Checking for long support..." and hung,
> not continuing for the time I let it sit at that screen (about 20 minutes).
> 
> My laptop is a Toshiba Satellite from 2012, it's 64-bit, has lots of ram
> and has inbuilt SSE 4.2 support, so I don't think it's my hardware.
> 
> Could anyone offer some pointers here? Thanks!

It seems I was lucky with my Acer Travelmate. All BIOS calls worked as
documented. But from the feedback I received meanwhile I get the
impression that this is rather the exception than the rule.

Most of today's BIOSes seem to implement only the absolute minimum,
which is understandable as modern OSes don't call the BIOS so much any
more.

This is a pity, and I don't know what to recommend. But at least
Qemu I would have expected to work ...

♪♫ Alex
-- 
UNSUBSCRIBE: mailto:picolisp@software-lab.de?subject=Unsubscribe

Reply via email to