> This is an error from the BIOS (Was this also Qemu?).

Yes, that was Qemu. Here's a screenshot <http://imgur.com/5bCRrVF.png>.

It comes after the "Loading PilOS" text, and I found the string constant
"READ ERROR 00" in the image binary (at 0xBF), so I thought that was PilOS.

I also recompiled using the provided source / instructions on the Wiki, and
tried booting the resulting "x86_64.bin" in Qemu and bare metal with the
same results.

> Most of today's BIOSes seem to implement only the absolute minimum,
> which is understandable as modern OSes don't call the BIOS so much any
> more.

My PC's BIOS is the same (un-updated) one it shipped with, but the trouble
with BIOSes is that it's unlikely to find two identical confiugurations on
any two systems. :)

> This is a pity, and I don't know what to recommend. But at least
> Qemu I would have expected to work ...

I was kinda looking forward to having a Lisp OS on bare metal, but maybe
this is why there aren't that many. :P
I'm all ears if you've any suggestions, and I'll definitely keep an eye on
development.

~ cat

On Fri, Apr 15, 2016 at 12:57 PM, Alexander Burger <a...@software-lab.de>
wrote:

> On Fri, Apr 15, 2016 at 12:08:56PM -0400, cat stevens wrote:
> > Hi! I am very interested in the idea and look of PilOS; however, I'm
> having
> > some issues trying to get started with it. Can I ask about those here?
>
> Sure! :)
>
>
> > First, the command on the Wiki seems to have an issue, which I asked
> about
> > here
> > <
> http://unix.stackexchange.com/questions/276480/booting-a-raw-disk-image-in-qemu
> >
> > -- it seems like it should be:
> >
> > qemu-system-x86_64 -drive format=raw,file=x86-64.img
>
> What I used for Qemu was
>
>    $ qemu-system-x86_64  -m 4096  -smp 4  -ctrl-grab  -no-reboot
> pilos/x86-64.img
>
> so it is similar to what you wrote in the above link, and it worked fine
> for me.
>
>
>
> > Even when I run that (apparently more correct) command, PilOS gives "READ
> > ERROR 09" and hangs.
>
> This is an error from the BIOS (Was this also Qemu?).
>
>
> > I also tried booting my laptop from the raw disk image written to a USB

Reply via email to