Thank you very much for that quick reply, Alex.

But no luck so far.

Thanks for your hints and explanations. Another install approach by downloading the apk from the softlab url finishes in the same result.

I'm using a SM-T719 tablet, which some day got the update to android 7 (german language) and I do not have any clue how to use it beyond 'open termux and do command line things' and 'open browser and do web view things' :-)

Storage permissions, though, I granted before :-)

It looks like I'm not able to share (senden (??) in german) 'the downloaded zip file' to the Pilbox app, because Pilbox App is not offered as target of that file action.

The dialog box Shares (german "Freigabe" is shown) offers Termux, TotalCommander, Bluetooth, Email, Wi-Fi Direct and others, but no Pilbox.

Little progress is shown on my dtek50 blackberry with android 6.0.1:
 + installed apk directly from your website,
 + granted storage+location permissions,
 + downloaded via firefox the zip files from your website
+ opened the 'Downloads' app (on bb/android 6.0.1 there is one, on sm-t719/android 7.0 there was 'Eigene Dateien')
 + tap on one of the zip entries
==> voila: start screen of Pilbox shows the buttons to launch the application so this is nearer to what's expected than on the other device/android combination

But all three tapped buttons result in a "Not Found" page - looks like this comes from the Pilbox local app server(?).

Might have to do with blackberry android specialities???, I don't know.

But it seems, that behaviour differs between android 6 and android 7 ?.

My GT-I9100 with android 4.1.2 (CyanogenMod I think) is too old to be supported by Pilbox, I guess.

By the way, the Settings screen of the bb/android_6 Pilbox lists the PILs as PIL-377 PIL-378 .... not as PIL-calc or PIL-hello as shown in the wiki article

So far for the moment,
I really have to quit now, no time to get involved deeper in the quest.

Greetings, Olaf

On 19.09.2017 10:18, Alexander Burger wrote:
Hi Olaf,

I'm very excited about your announcement, so I tried it out immediately :-)
Great! :)

Unfortunately I had no luck so far to 'pass the zip to the Pilbox kernel' -
tried it out with the provided and
The PilBox App needs permission to access storage. Did you enable it in the App
settings, as mentioned in the article (Then go to Apps -> PilBox -> Permissions
and enable "Location" and "Storage")?

Then it should work, if you e.g. click in a browser on the link and then open it (directly from the browser,
or by clicking on it in the "Downloads" App).

In the wiki there is written
When the PilBox kernel starts, it scans all top-level directories for other
files named "App.l".


What is ment by 'all top-level directories'?
All directories directly visible in the current working directory. This is the
one you see if you enter "$ ls -l" in the REPL. When the above passing of
'' worked, you would see a new directory 'hello/', and inside that

"Top-level" means that a file 'hello/foo/App.l' would *not* be considered, only
files 'App.l' one level below the working directory.

I tried the termux-share example and tried a download via Fireforx in
default Downloads directory, but without success.
After installing the Termux App, you need to call 'termux-setup-storage' one
time. It creates a directory tree with symbolic links to globally accessible
disk areas. In my case this resulted in

    total 72K
    lrwxrwxrwx 1 u0_a67 u0_a67 24 May 28 10:04 dcim -> /storage/emulated/0/DCIM/
    lrwxrwxrwx 1 u0_a67 u0_a67 28 May 28 10:04 downloads -> 
    lrwxrwxrwx 1 u0_a67 u0_a67 26 May 28 10:04 movies -> 
    lrwxrwxrwx 1 u0_a67 u0_a67 25 May 28 10:04 music -> 
    lrwxrwxrwx 1 u0_a67 u0_a67 28 May 28 10:04 pictures -> 
    lrwxrwxrwx 1 u0_a67 u0_a67 19 May 28 10:04 shared -> /storage/emulated/0/

So I can do things like

    $ cp ~/storage/downloads/
    $ termux-share ~/storage/downloads/

I hope this works for you :)
♪♫ Alex


Reply via email to