Hi all,

I have a small armel board (armv5tel), currently running emDebian Grip 7.1
(wheezy) for Home Automation. Because it's time to change to a newer
distribution, I was facing 'stretch' - but... I need NodeJS!

As everybody may know, the required v8 dropped support for armel some years
ago, you may read bug #818552 [1] for some background.

But for my needs, I'd be happy with any NodeJS v0.10.x release, so I had
several ideas:

   - port jessie's nodejs_0.10.29~dfsg-2 to use libssl1.0.2
   - statically link libssl1.0.1t with jessie's nodejs_0.10.29~dfsg-2
   - do one if the above with any nodesource release, running libv8 version
   <=3.17 (latest is 0.10.48 according [2])
   - when everything fails, I'd have to go with jessie

But unfortunately none of these ideas worked until now!
As many things might be complicated, I'd like to start focusing on two

   1. How do I compile official nodejs_0.10.29~dfsg-2 on jessie, passing
   all tests?
   2. How do I statically link libssl (omitting '--shared-openssl') with
   official nodejs source?

I even started to stay on armhf on armv7l, which should not suffer on any
v8 code changes, but I'm unable to compile and pass 'test-simple'.
The easy way of just taking built armel packages for jessie would be my
last resort, but I don't feel comfortable with that, when the tests are not
passing on my hardware.

Until now, I'm running nodejs_0.10.29~dfsg-1~bpo70+1 from wheezy-backports
without noticable problems, but I never tried to run tests from a compiled
Could anyone confirm that tests are not passing on armel or point me to
what I'm doing wrong?

Thanks, Sven.

[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=818552
[2] https://nodejs.org/en/download/releases/
Pkg-javascript-devel mailing list

Reply via email to