Hi,

As you already know, in Qt 5.6 there was a change in ELF versions, from @Base
to @Qt_5. I have developed a script for that (migrate-symbols.py) that scans
the build log and updates the symbols files accordingly. That script changed
the ELF version tags, but it did not touch the package version numbers.

Now I have a bug: qttools5-dev-tools dependency on libqt5help5 is not enough:
it depends on libqt5help5 (>= 5.0.2), however fails to work with 5.5:

/usr/lib/x86_64-linux-gnu/qt5/bin/qhelpgenerator: 
/usr/lib/x86_64-linux-gnu/libQt5Help.so.5:
version `Qt_5' not found (required by 
/usr/lib/x86_64-linux-gnu/qt5/bin/qhelpgenerator)

How can I make sure a proper dependency is generated?

Using -V flag of dh_makeshlibs does not help.

Of course I can bump all symbols versions to 5.6.0~beta, but I don't think it
is a proper solution (and also it will destroy the existing symbols history).

Does anyone know a better solution?

--
Dmitry Shachnev

Attachment: signature.asc
Description: PGP signature

-- 
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-talk

Reply via email to