There is a 'select' method already used form inputs but I guess it is okay to have two DOM methods with the same method name doing completely different things.
http://www.w3schools.com/htmldom/met_text_select.asp At same time, I could see someone building an HTML editor using prototype.js or a just browser wanting to add a 'select' method to the DOM that was similar to the input.select(), it would select the innerHTML of an element. ~ jake On Aug 29, 4:47 pm, "Nicolás Sanguinetti" <[EMAIL PROTECTED]> wrote: > On 1.6.0 this has been aliased to select > > $("my-element").select("a[href=foo]") > > -Nicolas > > On 8/29/07, Jacob Rockowitz <[EMAIL PROTECTED]> wrote: > > > Hi, > > > I have been using Element#getElementsBySelector a lot and keep feeling > > that the method's name is too verbose, couldn't it just be an Element#$ > > $. > > > ex: > > > instead of > > $('my-element').getElementsBySelector('a[href="foo"]'); > > it could be > > $('my-element').$$('a[href="foo"]'); > > > I understand that the usage of the $ is for utility functions but this > > seems like a reasonable idea. > > >http://dev.rubyonrails.org/ticket/9424 > > > thanks > > ~jake --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "Prototype: Core" group. To post to this group, send email to [email protected] To unsubscribe from this group, send email to [EMAIL PROTECTED] For more options, visit this group at http://groups.google.com/group/prototype-core?hl=en -~----------~----~----~----~------~----~------~--~---
