Re: "I strongly disagree that put/delete methods are 'unsupported'"
With regards to the client. Or has this changed recently?

Re: "But I also think that by default put/delete should not use method
overriding"
Agreed. They should be plain vanilla put/delete. If the client does
not support them put/delete should not exist. Rather let the developer
then implement some form of method override himself.

Propose we rename "onFailure" to "onError". Good looking. Faster to
type.

The response headers' case should not be implicitly altered. E.g.
'Content-Type' should not be cased to 'content-type' etc. The
developer should be able to handle any case discrepancies. These
requests would mostly be same-origin, where the developer would have
control over the response headers.

Perhaps we could also look at incorporating support for cross-origin
HTTP? There a number of methods that could be abstracted over, such as
Kris Zyp's WindowNameRequest for example?

-- 
You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to prototype-core@googlegroups.com
To unsubscribe from this group, send email to 
prototype-core-unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/prototype-core?hl=en

Reply via email to