On Thu, Feb 4, 2010 at 17:29, Joran Greef <jorangr...@gmail.com> wrote:
> > Re: "But I also think that by default put/delete should not use method > overriding" > Agreed. They should be plain vanilla put/delete. If the client does > not support them put/delete should not exist. > I think that I've tested it more than a year ago and that all our supported browsers did HEAD, PUT, DELETE without problem. It was the other HTTP methods where there were more differences. > Propose we rename "onFailure" to "onError". Good looking. Faster to > type. > onFailure was chosen as opposite to onSuccess > Perhaps we could also look at incorporating support for cross-origin > HTTP? There a number of methods that could be abstracted over, such as > Kris Zyp's WindowNameRequest for example? I would be happy with JSONP. -- You received this message because you are subscribed to the Google Groups "Prototype: Core" group. To post to this group, send email to prototype-core@googlegroups.com To unsubscribe from this group, send email to prototype-core-unsubscr...@googlegroups.com For more options, visit this group at http://groups.google.com/group/prototype-core?hl=en