On Mon, Oct 17, 2016 at 07:39:23PM +1000, Nathan Woodrow wrote:
> Sandro,
> Have a read of the links that Even posted.  They don't really side in
> favour with the idea of sandboxing Python, and that was just plain
> python not including PyQt4, etc,
> https://lwn.net/Articles/574215/

Indeed also PostgreSQL dropped the "trusted" version of plpython
as of version 7.4 because of lack of sandboxing support upstream:
As of PostgreSQL 7.4, PL/Python is only available as an "untrusted"
language, meaning it does not offer any way of restricting what users
can do in it. It has therefore been renamed to plpythonu. The trusted
variant plpython might become available again in future, if a new
secure execution mechanism is developed in Python.

But I like to be supportive with whoever wants to change the world :)

Qgis-developer mailing list
List info: http://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-developer

Reply via email to